Could not load file or assembly 'Microsoft.Practices.Unity' or one of its dependencies.

Aug 22, 2012 at 2:55 PM

Download this project and try to compiled, it compiles good, but on runtime it is throwing following error.

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: The value of the property 'type' cannot be parsed. The error is: Could not load file or assembly 'Microsoft.Practices.Unity' or one of its dependencies. The system cannot find the file specified.

Source Error: 

Line 83: 	<unity>
Line 84: 		<typeAliases>
Line 85: 			<typeAlias alias="Singleton" type="Microsoft.Practices.Unity.ContainerControlledLifetimeManager, Microsoft.Practices.Unity"/>
Line 86: 			<typeAlias alias="Transient" type="Microsoft.Practices.Unity.TransientLifetimeManager, Microsoft.Practices.Unity"/>
Line 87: 			<typeAlias alias="PerWebRequest" type="Kigg.Infrastructure.EnterpriseLibrary.UnityPerWebRequestLifetimeManager, Kigg.Infrastructure.EnterpriseLibrary"/>


Source File: C:\Projects\KIGG\Web\web.config    Line: 85 


Show Additional Configuration Errors:

The value of the property 'type' cannot be parsed. The error is: Could not load file or assembly 'Microsoft.Practices.Unity' or one of its dependencies. The system cannot find the file specified. (C:\Projects\KIGG\Web\web.config line 86)


Version Information: Microsoft .NET Framework Version:2.0.50727.5456; ASP.NET Version:2.0.50727.5459

 

 

 

Please Note:

1) I am having all the things as mentioned in system requirement.

2) I have performed all configuration steps. (Including DB Scripts)

3) I am using default configuration (LINQ2SQL)

4) While searching for solution on internet i have found this link, may be someone can please help me with this.

http://stackoverflow.com/questions/4469929/could-not-load-file-or-assembly-or-one-of-its-dependencies

 

Please help me, I am struggling with error since yesterday.

Thank you.

Developer
Sep 2, 2012 at 12:18 PM

Hi There,

I am sorry for the late reply. Let me know if you are still having problems with the installation.

Try to clean Debug and Release folders in your solution. Ant then remove and add unity again.

Pass your skypeid so that I can see where you are getting the error.

Click on my username and contact me so that I can help you in assisting the installation.

Cheers,

Narendra

Visit my kigg based Sharepoint community site

 

 

 

 

 

Sep 3, 2012 at 2:53 PM

Thank you Narendra for replying...  

Is it possible to resolve this problem other than talking on skypee?  From my work place we are not allowed to install skypee or any third party chat client.

 

Let me briefly explain what i am doing?

I did a fresh installation of Win 7 OS, then installed VS.Net 2008, download vs.net 2008 sp1, then installed sql server 2008 express.

I then Downloaded Kigg project and open Kigg.sln project file and follow step by step to configure things.

I have reference all correct .dll files as available in Reference folder, did clean/rebuild as u mentioned above, but still i am facing the same issue.

I would appreciate if you can please let me know what Microsoft.Practices.Unity .dll's we need to reference for Kigg and Url to download it.  Thank you.

 

 

Could not load file or assembly 'Microsoft.Practices.Unity.Interception.Configuration' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded. C:\Projects\KIGG\Web\ASPNETCOMPILER Kigg.Web

 

Please Note:

1) I am having all the things as mentioned in system requirement.

2) I have performed all configuration steps. (Including DB Scripts)

3) I am using default configuration (LINQ2SQL)

4) While searching for solution on internet i have found this link, may be someone can please help me with this.

Developer
Oct 7, 2012 at 12:29 PM

Hi There,

Hope you are doing alright there.

Which version of the source code you are dealing with? 

It is pretty difficult to debug without looking at the problem. Please make sure that you are compiling the web app with target framework of ".NET Framework 3.5" and see how it goes. In order to do this, right click on the kigg.web project and click on the properties. In the "Application" tab, there is a Target framework dropdown where you select .NET Framework 3.5 and save the project. Now rebuild your web app and it should work. If necessary do this for all the projects in the solution and rebuild the whole project.

Again it is very difficult to debug without looking at the problem. The above solution might work or might not work for you.

It depends on the which version of the source code you downloaded. Let me know how it goes and I will give you a stable version that I have just found in my old lappy which is working just fine in my lappy with VS 2010. Again it depends on your system build.

Cheers,

Narendra

sharepoint community site

Sep 4, 2013 at 3:03 PM
Hi, Have you find the solution on this finally?
I am facing same issue????