Story does not exist

Jan 14, 2009 at 3:14 PM
I just installed the latest build (17948) in VS2008, set the web project to startup, and ran the app.

I got a "Story does not exist" exception with the following stack:
   at Kigg.Web.BaseController.
ThrowNotFound(String message) in C:\Documents and Settings\Sean.Campbell\My Documents\Kigg-17897\v2.x\Web\Controllers\BaseController.cs:line 149
   at Kigg.Web.StoryController.Detail(String name) in C:\Documents and Settings\Sean.Campbell\My Documents\Kigg-17897\v2.x\Web\Controllers\StoryController.cs:line 248
   at lambda_method(ExecutionScope , ControllerBase , Object[] )
   at System.Web.Mvc.ActionMethodDispatcher.Execute(ControllerBase controller, Object[] parameters)
   at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(MethodInfo methodInfo, IDictionary`2 parameters)
   at System.Web.Mvc.ControllerActionInvoker.<>c__DisplayClassc.<InvokeActionMethodWithFilters>b__9()
   at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodFilter(IActionFilter filter, ActionExecutingContext preContext, Func`1 continuation)

It look like a string of "default.aspx" is being passed in to StoryController.Detail() as the 'name' variable.


Am I doing something wrong?
Developer
Jan 16, 2009 at 4:07 PM
Hi, seano288!

You must enter solution under right-configured IIS (if you install IIS after .net 3.5 you must run aspnet_iis -i command to configure IIS) to resolve your problem.
Set new site, bind it to 127.0.0.1 and run, enjoy your Kigg :)

I hope, it help. Have a nice day and sorry for my English.
Jan 19, 2009 at 3:40 PM
Thanks XaocCPS but I don't have IIS installed at all.  I was hoping to work on this fully within VS2008.  Is this not possible? What prevents VS2008 from running this?

Thanks.
Developer
Jan 19, 2009 at 4:13 PM
Hi, seano288!
There is no another solution for me. IIS exists in any windows, is it problem to enable IIS in your windows?

Coordinator
Jan 19, 2009 at 6:46 PM
IIS is not required to run it locally, you can use the Visual Studio Web Server. Just change the RootUrl of web.config.

<type type="IConfigurationSettings" mapTo="ConfigurationSettings">
    <lifetime type="Singleton"/>
    <typeConfig extensionType="Microsoft.Practices.Unity.Configuration.TypeInjectionElement, Microsoft.Practices.Unity.Configuration">
        <property name="RootUrl" propertyType="System.String">
            <value type="System.String" value="http://localhost/Kigg"/> <!--YOUR LOCAL URL -->
    </property>
Jan 28, 2009 at 4:59 PM

I tried changing the RootUrl in my webconfig to
<value type="System.String" value=http://localhost:1080/>
That's what VS2008 set it to.  But I still get the 'Story does not exist' error.

I've set up permissions on the SQL db and everything on that end is fine, but can't get past this error.  Any suggestions?
Here is the full error:

   at Kigg.Web.BaseController.ThrowNotFound(String message) in C:\Projects\General\Kigg\Kigg-18042\v2.x\Web\Controllers\BaseController.cs:line 149
   at Kigg.Web.StoryController.Detail(String name) in C:\Projects\General\Kigg\Kigg-18042\v2.x\Web\Controllers\StoryController.cs:line 327
   at lambda_method(ExecutionScope , ControllerBase , Object[] )
   at System.Web.Mvc.ActionMethodDispatcher.Execute(ControllerBase controller, Object[] parameters)
   at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(MethodInfo methodInfo, IDictionary`2 parameters)
   at System.Web.Mvc.ControllerActionInvoker.<>c__DisplayClassc.<InvokeActionMethodWithFilters>b__9()
   at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodFilter(IActionFilter filter, ActionExecutingContext preContext, Func`1 continuation)

 

Apr 9, 2009 at 7:14 PM
I'm having the same error.  'Story does not exist.'  And the story that is trying to load is default.aspx.
Coordinator
Apr 9, 2009 at 8:19 PM
Just delete the Default.aspx and run again.
Apr 14, 2009 at 3:01 PM
I'm still having trouble accessing the root default.aspx page either by starting with this page or by typing it in or by accessing it via the 'All' menu item.  I am using release 2.2.  I have deleted the default.aspx page (suggested above) and it did not help.  I can access the faq, about, submit, login page as well as the other category pages but not the home page.  I have followed the 10 steps in the readme.txt except I am running locally using the visual studio web server.  The error I get is 'Story does not exist' related to default.aspx.  If I turn on the custom errors I get a 404 error.  I do not get the"No published story exists." message on the home page per step 10 of the readme.txt.  Any suggestions?  Thanks for your help.
May 12, 2009 at 1:57 PM
Edited May 12, 2009 at 3:36 PM

When I delete the Default.aspx and run again,the IE show Cannot find the page

but when I donot Default.aspx there are a error 'Story does not exist.' And the story that is trying to load is default.aspx.

Who Can help me!

I have

SQL 2005

VS2008

iis 6.0

Jun 24, 2009 at 7:37 PM

even i have the same problem. i changed my rooturl to  <value type="System.String" value="http://localhost:49731/"/> but still, it says story does not exist.

 

anybody help please