Kigg 2.0 Installation on Windows 2008/SQL2008

Jan 23, 2009 at 12:59 PM
Hi everyone,

I have tried to install Kigg 2.0 on Windows 2008 and SQL 2008.

There are in fact no installation instructions (except some 10 lines in a text file) and I tried a lot, but up till now have not been able to get anything other than some error messages.

Could anyone please post a more detailled installation instruction doing it from scratch?

1. I created the database in SQL2008 via Database\Create.Sql
2. I Populated some data in it via the Database\Data.sql script
3. I created a virtual directory in IIS named Kigg (I put it right into wwwroot, so I can reach it via http://localhost/kigg)
4. I created accounts at websnapr.com and recaptcha.net
5. I opened the minimal.config in an editor
6. I Renamed minimal.config to web.config
7. I replaced the YOUR- with meaningful values
8. I opened the kigg.sln and ran

So much for the description in the textfile :-(

Now the problems:

1. The textfile does not mention anything about the database connection string. You have to modify it to use anything other than sqlexpress.
2. The textfile does not mention anything where you have to point the virtual folder to. I figured it had to be the Web subfolder of the v2.x folder?
3. After doing this the webpage shows an error complaining that the webpage is not an application, so I converted the virtual folder to an application and put the Classic .NET AppPool in.
4. The textfile does not mention anything about security, authentication, authorization etc. I am a bit lost here what the application does need to work without having to open everything for all people out there.
5. Now the webpage tells me "Server Error in /kigg Application" The ressource cannot be found. Requested url: /kigg/default.aspx. At that point I do not know what else to do.

Thanks for your help!

CU
   Andreas Kroll




Coordinator
Jan 23, 2009 at 2:08 PM
Sorry Andreas, I should write in more detail steps. Let me clarify the steps you mentioned.
1. Yes you need to correct the connection string.
2. Yes the web under the 2.x directory.
3. No for IIS 7 it will run in DefaultAppPool.
4. N/A
5. For II7 you do not need the Default.aspx file. Click the Properties->Web of the Web Project, then set Start Action to blank string (specific page)

I hope this will solve your issues.

Feb 4, 2009 at 3:49 PM
Hi Andreas,

Did you get past the 'Resource cannot be found' error? Kazimann - are you saying that this is just a connection string problem?

Cheers,
Steve Walsh
Coordinator
Feb 4, 2009 at 6:03 PM
Steve,

Pls follow the read me file. If you still unable to configure, do let me know.
Feb 4, 2009 at 8:10 PM
Hi Kaziman,

I have followed the set up in the read me file, and I have run it through the debugger. It is failing in StoryController.Detail and throwing the exception 'Story does not exist' when looking for a story with the name 'Default.aspx'. Does this give you any clues as to how I can solve the problem?

Cheers,
Steve
Coordinator
Feb 4, 2009 at 8:33 PM
Hi Steve,

The Default.aspx is not at all need, it was just added for backward compatibility. Click Project->  Web of the Web Project and check the radio button "Specific Page" and set blank string save and hit run.
Feb 5, 2009 at 9:02 AM
Hi Kaziman,

I have followed your suggestion, but it just results in a HTTP 403 Forbidden error.
Coordinator
Feb 5, 2009 at 12:40 PM
That is interesting, Usually the 403 error code is thrown when the ip address is blocked, which is never should be the case if you are running a clean install, I would suggest you check the Web/App_Data/blockedIPList.txt file. BTW are you running it in IIS7 or Visual Studio Integrated web server?
Feb 5, 2009 at 2:40 PM
The bocked IP address file is empty. I am running this on my local machine so the IP address will be 127.0.0.1. I have tried both the IIS and the VS Integrated Web server.
Coordinator
Feb 5, 2009 at 3:23 PM
Hi Steve,

You mentioned in the previous post that you it hitting he Default.aspx, is it currently showing 403 without showing the home page, I am more curious to learn at what point it is throwing 403?
Feb 5, 2009 at 3:47 PM
Hi Kaziman,
I expect that the 403 error is due to directory permissions as there is no default page set for the web site. If I set Default.aspx as the default page, then we are back where we started, but I can't see an alternative page?
Coordinator
Feb 5, 2009 at 4:16 PM
Hi Steve,

This is as same as configuring any ASP.NET MVC application except in IIS it only runs in version 7.0
Feb 5, 2009 at 4:31 PM
Aha - looks like I need an IIS upgrade! Thanks so far...
Coordinator
Feb 5, 2009 at 7:44 PM
If you need help do let me know.
Feb 5, 2009 at 7:51 PM
Many thanks, Kaziman. It will probably have to wait until the weekend when I can go through the process on a spare machine.
Feb 5, 2009 at 8:22 PM
Edited Feb 5, 2009 at 8:46 PM

Hi all.

I'm having a similar problem. I have a clean install of win server 2008. i've installed VS 2008 sp1 and asp.net MVC RC.
dowloaded kigg, followed the txt file instructions, changed the sql connectio, but i get this error:
404 The resource cannot be found.

the error appears in StoryController.Detail. The Detail method input parameter "name" has a value of "default.aspx".
after this line in StoryController.cs (method Detail) runs
IStory story = _storyRepository.FindByUniqueName(name);
the story is null so it throws an exception on the next line.

Now in the Properties->Web  of the Kigg.Web project i have these settings:
Specific Page is checked and set to empty.
Apply server settings to all users is checked
Use Visual Studio Development Server is also checked with auto assign port checked.
Virtual Path is set to /Kigg

I've also tried with IIS also on the Properties->Web of the Kigg.Web
Checked Use local IIS web Server.
set Project URL to "http://localhost/Kigg" and clicked the button Create Virtual Directory
also tried running with Override application root URL checked and unchecked.
The app is running in DefaultAppPool. I have checked in IIS manager
this is the error i get:

Value cannot be null.
Parameter name: httpContext

KiGG\Web\Extension\ControllerContextExtension.cs Line: 10

public static UrlHelper Url(this ControllerContext controllerContext)
{
 return new UrlHelper(new RequestContext(controllerContext.HttpContext, controllerContext.RouteData)); // this is line 10
}

Losing my mind here :)
Mladen

Coordinator
Feb 8, 2009 at 7:53 PM
If you are still having problem configuring it, checkout my following blog post:

http://weblogs.asp.net/rashid/archive/2009/02/09/installing-kigg.aspx
Feb 9, 2009 at 9:57 AM
thanx!
i'll try it out and reply back here if it doesn't work.
Coordinator
Feb 9, 2009 at 10:47 AM
Sure, no problem.
Feb 9, 2009 at 3:40 PM
Hi,

I am have similar problems:
I am trying to run your code on a Vista machine with the VS web server and I keep getting 'page not found' errors.
I followed your instructions to the letter (except the IIS part) as shown in the screencast.

While trying to debug this issue, I noticed that in the StoryController.cs file, in the "Detail(string name)" method, the 'name' parameter is always "default.aspx" - is that normal?
(I made sure that the startup page is an empty string as you suggested)

Your application looks very promising but in the last couple of days, I am starting to get a few extra gray hairs trying to make it work :-(


Thank you for everything...
Coordinator
Feb 9, 2009 at 4:34 PM
Can you pls delete the Default.aspx and try again.
Feb 9, 2009 at 4:49 PM
hey, this simple solution solved my problem

thanks!
Coordinator
Feb 9, 2009 at 4:57 PM
Great
Feb 9, 2009 at 9:33 PM
hey!
I used the VS integrated web server and deleting Default.aspx has solved the problem.
but why did it solve it?
Mar 9, 2009 at 8:44 PM
Hi, I tried watching the video, but it's really blurry. Is there anyway of getting a clearer version? Thanks, John
Aug 30, 2010 at 1:56 PM

Hi All,

 

I installed kigg at domain http://ikick.in/

 

but getting error 403. Can anyone help me out ?

 

Its windows 2008 server with IIS 7 & MVC installed.