rootUrl

Mar 25, 2009 at 7:25 AM
I have a problem setting a correct root url. I typed "http://deathsquad.pl/KiGG" as a RootUrl in web.config and everything works fine except submitting new stories. When I click submit it redirects me to "http://deathsquad.pl/KiGG/KiGG/story_name". Im a MVC rookie and I just can't figure out the correct setting. When I set rootUrl simply to "http://deathsquad.pl" it crashes with NullException during the submit of a new story.

Server config:
Win 2k8
IIS7
ASP.NET 3.5
MVC RC1

Mar 25, 2009 at 9:33 AM
Edited Mar 25, 2009 at 9:34 AM
Try  "http://deathsquad.pl/"
Mar 25, 2009 at 9:47 AM
I said I did. It throws unexpected error during submit
Mar 25, 2009 at 9:59 AM
Edited Mar 25, 2009 at 10:03 AM
Did you tried with "/" at end of url ?
 <value type="System.String" value="http://deathsquad.pl/"/>

 

 

 

 

Mar 25, 2009 at 10:05 AM
yes :(
Mar 25, 2009 at 10:07 AM
such error with http://deathsquad.pl/

Timestamp: 3/24/2009 7:08:51 PM
Message: HandlingInstanceID: 6c95d426-59f6-4405-a21f-27789fa12040
An exception of type 'System.NullReferenceException' occurred and was caught.
-----------------------------------------------------------------------------
03/24/2009 20:08:51
Type : System.NullReferenceException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Message : Object reference not set to an instance of an object.
Source : Kigg.Core
Help link :
Data : System.Collections.ListDictionaryInternal
TargetSite : Void Process(System.String, Boolean, System.String, Kigg.DomainObjects.IStory)
Stack Trace : at Kigg.Infrastructure.SpamPostprocessor.Process(String source, Boolean isSpam, String storyUrl, IStory story) in J:\Projekty\KiGG-v2.1\Core\Infrastructure\Spam\SpamPostprocessor.cs:line 37
at Kigg.Service.StoryService.<>c__DisplayClass6.<Create>b__4(String source, Boolean isSpam) in J:\Projekty\KiGG-v2.1\Core\Service\StoryService.cs:line 124
at Kigg.Infrastructure.DefaultSpamProtection.<>c__DisplayClass6.<IsSpam>b__0(String response) in J:\Projekty\KiGG-v2.1\Core\Infrastructure\Spam\Default\DefaultSpamProtection.cs:line 99
at Kigg.Infrastructure.CachingHttpForm.GetAsync(String url, Action`1 onComplete, Action`1 onError) in J:\Projekty\KiGG-v2.1\Core\Infrastructure\Http\Decorated\CachingHttpForm.cs:line 65
at Kigg.Infrastructure.DefaultSpamProtection.IsSpam(SpamCheckContent spamCheckContent, Action`2 callback) in J:\Projekty\KiGG-v2.1\Core\Infrastructure\Spam\Default\DefaultSpamProtection.cs:line 81
at Kigg.Service.StoryService.Create(IUser byUser, String url, String title, String category, String description, String tags, String userIPAddress, String userAgent, String urlReferer, NameValueCollection serverVariables, Func`2 buildDetailUrl) in J:\Projekty\KiGG-v2.1\Core\Service\StoryService.cs:line 124
at Kigg.Web.StoryController.Submit(String url, String title, String category, String description, String tags) in J:\Projekty\KiGG-v2.1\Web\Controllers\StoryController.cs:line 456

Additional Info:

MachineName : AUKIDF-8G-2008
TimeStamp : 3/24/2009 7:08:51 PM
FullName : Microsoft.Practices.EnterpriseLibrary.ExceptionHandling, Version=4.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
AppDomainName : /LM/W3SVC/1/ROOT/af-1-128823952694390809
ThreadIdentity : turek
WindowsIdentity : ZARZĄDZANIE NT\USŁUGA SIECIOWA

Category: FullException
Priority: 1
EventId: 0
Severity: Critical
Title:KiGG Exception
Machine: AUKIDF-8G-2008
Application Domain: /LM/W3SVC/1/ROOT/af-1-128823952694390809
Process Id: 4924
Process Name: c:\windows\system32\inetsrv\w3wp.exe
Win32 Thread Id: 3568
Thread Name:
Extended Properties:


Mar 25, 2009 at 10:12 AM
Edited Mar 25, 2009 at 10:23 AM
I also have the same problem on my site, but only for users accounts. Admin can post new story without problems.
Mar 25, 2009 at 10:29 AM
Edited Mar 25, 2009 at 10:31 AM
what was the default admin pass ?

i will try to disable spam protection when i get home
Mar 25, 2009 at 10:32 AM
Edited Mar 25, 2009 at 10:34 AM
the same as login.
Read also http://kigg.codeplex.com/Thread/View.aspx?ThreadId=45152
Mar 25, 2009 at 4:37 PM
Edited Mar 25, 2009 at 8:17 PM
I checked your kigg-site and i get 500 internal server error  when i click to
http://deathsquad.pl/KiGG/Krajowy-Rejestr-D%C5%82ug%C3%B3w-Biuro-Informacji-Gospodarczej-SA-Strony-Informacyjne-KRD-BIG-SA

I also have similar problem with links that has symbol "�" from non-utf-8 sites. Just see my kigg-site - http://geptard-2.hosting.parking.ru/Upcoming
Mar 25, 2009 at 7:16 PM
this is caused by national characters (im from poland). I have to make a mask that will change them to qwerty standards. just like they did in www.dotnetomaniak.pl
Mar 25, 2009 at 8:40 PM
Edited Mar 25, 2009 at 8:44 PM

www.dotnetomaniak.pl - nice site.
On this site fixed another my problem  - the right ends of word "netomaniak" for different numbers. This is important for Polish and also Ukrainian languages:
1 .netomaniak
3 .netomaniaki
6 .netomaniaków

In kigg for all numbers showed only one word "shouts"

Sorry for my not perfect english.

 

Mar 25, 2009 at 9:33 PM
yeah, guys did a pretty good job. im making a military digg.com for polish military/asg/paintball/milsim community
Apr 7, 2009 at 9:08 AM
Hi guys,

In regards to the exception that user turowicz is getting, I fixed this in dotnetomaniak.pl. I don't have access to my source code now, so I will post my solution later today. I'm not sure if my solution is 100% as it should be, but it works. During the translation, we had lot's of trouble with our very beautiful polish language :), but I think we did a good job. I might be of help if somebody needs polish translation of Kigg. I was thinking of creating seperate files package containing only polish translation, but because the changes are scattered all over the code I dropped the idea :(

Kind regards,
Pawel Lukasik
Apr 7, 2009 at 4:08 PM
Ok. Now I have access to my source code so I can post my change. It was as simply as commenting out line 36 from SpamPostprocessor.cs.

IStory approvingStory = _storyRepository.FindById(story.Id); // comment this out

I don't know why it tries to look for the story in repository because the Process method already have this story as one of the parameters (maybe somebody can explain this to me). So now it just calls .Approve on story parameter that is supplied to the method. Everything looks ok.

I hope this helped.

Kind regards,
Pawel Lukasik
Coordinator
Apr 7, 2009 at 4:31 PM
Pawel, The SpamPostProcessor runs on another thread so the actual L2S context that gets the story is not the same L2S context which is required to update the story.
Apr 7, 2009 at 5:29 PM
Kazi. Thanks for the explanations. I see (in another thread) that you have solved this issue. I will grab the latest version and check how did you solved that.