Installation issue on web host server

Nov 3, 2009 at 7:00 PM

Hi everyone,

First I want to say that Kigg is a great program and I'm hoping to get it running on my web host server to appreciate it to it's fullest extend. Please bare with me as I'm not a professional programmer and still have a lot to learn. I followed the instruction to install KiGG and here's what I did:

1- Completed Clean Install successfully

2 - I get the following error:

Compilation Error

 

 3 - I changed NETWORK SERVICE to Full Trust and still get the same error

4 . I assumed the problem is my server, so I published the built website to My Web Server hosting and I get an access denied error as well.

I contacted the host and they say it has to have an index page or a starting page to work!!

Can you please provide a clear Installation instruction of how to install this great program directly on a web server? and specifiy which download should be used for deployment.

Thanks again and hope to hear from you soon.

Regards

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. 

Compiler Error Message: CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\kigg\b9b5626e\a988d17f\App_global.asax.agqbwfqo.dll' -- 'Access is denied.

 

Nov 4, 2009 at 11:27 PM

Any suggestions?

Why am I getting this error?

I've set the Specific page to blank screen and applied server setting to all users. but I still get this error.

Any suggestion is appreciated.

Thank you

Nov 5, 2009 at 8:29 PM
Edited Nov 5, 2009 at 8:49 PM

OK, This is what I did:

1. I downloaded KiGG 2.5 Web and Database Script (Release Build) (Recommended default)  and Extract the Zip in a Directory (e.g. C:\Projects\KiGG)
- Done

2. Created Web Folder named KiGG (e.g. C:\Projects\KiGG\Web) as Application in IIS7 manager. Ensure that application pool is set to Default. (Skip this step, in case you are using Integrated Web Server of Visual Studio)

- Done

 3. Now Open and execute the Create.sql script from Database Folder (e.g. C:\Projects\KiGG\Database\Create.sql) and run in SQL Management Studio.
- Done

4. Next Open and execute the Data.sql from the Database folder (e.g. C:\Projects\KiGG\Database\data.sql) to populate some tag/category.
- Done

5. Change the Database Connection String.

6. Created an Account in http://www.pageglimpse.com/ and put the developer's key in unity.ef.config line 412.

7. Created an Account in http://recaptcha.net and put API Keys in unity.ef.config lines 984 & 987

8. in Visual studio set Start Options to "Specific Page" and left the value Blank

9. Built and run

10. I only get the Directory Index and not able to pull up the site!

Where did I go wrong??

Thanx

Nov 10, 2009 at 11:10 PM

Resolved.

Jan 22, 2010 at 3:20 PM

Hello Geneboss,

    I too followed the same step as mentioned by you on Nov 6 2009, but no luck for me . Will you please suggest me what i need to do for it.

I am getting

 

The website declined to show this webpage

<!-- This row is for HTTP status code, as well as the divider-->  HTTP 403 <!-- Error Body -->  

Most likely causes:

  • This website requires you to log in.
Jan 25, 2010 at 4:18 PM
geneboss wrote:

Resolved.

Maybe you could share the solution for others?

Jan 29, 2010 at 6:09 AM

Hello,

You need to contact your host server and ask them to set up Wildcard Application Mapping for your domain. This should take care of this issue.

Good Luck

Jan 29, 2010 at 6:18 AM

Thanks Geneboss for answering, but I am using localhost for time being. but have no clue how to solve this problem.

 

Jan 29, 2010 at 7:11 AM

OK...

--Check the %systemroot% folder to see if a Temp folder exists, if not, then create it.
--Create Full permissions on the Temp folder to my network service account.
--in Control panel go to System and Maintenace --> System --> ;On the "Advanced" tab, click "Environment Variables"
--Select the temp variable under "System Variables", and then click edit.
--Type %systemroot%\Temp in the variable value box, and then click OK.
Repeat the steps in 4 and 5 to edit the "TMP" variable, and then click OK twice.
Restart IIS service, click "Start" - "Run" - "IISRESET"
This will reset the IIS service.

This should solve the problem.

Jan 29, 2010 at 7:37 AM

Thanks again Geneboss, for taking all the trouble to explain this in detail.

I followed just as you suggested. but still no luck Geneboss.

If you have some free time you, we can either do chat or u can access machine by Teamviewer. Please let me know. Thanks once again.