This project is read-only.

Blank Page

Mar 28, 2009 at 12:55 AM
I have installed my version of Kigg but I only get a blank page when running it. Can anyone help?
Apr 15, 2009 at 9:25 AM
It's hard to say having so litte information provided. Are you using IIS 7 or IIS 6? Is there any info in logs files?
Apr 15, 2009 at 10:56 AM
Could you please provide more information!
Did you configured your kigg web application as per read me file?!
Apr 15, 2009 at 4:32 PM
I get a blank page on trying to use the Openid Login.

The error that it emails

 Message: This operation requires IIS integrated pipeline mode.
 Category: FullException
 Priority: 1
 EventId: 0
 Severity: Critical
 Title:

I am running IIS6, is there a work around for the pipline mode?  2.1 is the Kigg version.



Apr 15, 2009 at 4:37 PM
Edited Apr 15, 2009 at 11:51 PM
As mentioned that we would not be able to give support on IIS6, pls upgrade to IIS7
Apr 15, 2009 at 5:08 PM
Thank You, you guys are great on support.  There was no question that you will support it.
So, the actual question is:  Will the OpenID work with II6?  What do I have to do to II6 some that it does not throw the exception?  or where can I figure it out to share with the community?

I looked at some of the things that Phil Haack wrote, but could not find the answer.

Thanks again you guy wrote some great stuff.
Apr 15, 2009 at 11:52 PM
Sorry it should be "not ". I think you better post this issue in the ASP.NET MVC Forum or if you think it is related with DotNetOpenID then I would suggest its google project page.
Jan 25, 2010 at 7:12 PM

Two things. Firstly, see my post that solves the OpenID issue on IIS6: http://kigg.codeplex.com/Thread/View.aspx?ThreadId=50125

Then I found that all I needed to do to support IIS6 was to do the following:

  • Virtual Directory Properties -> Home Directory Tab
  • Configuration -> Mappings Tab
  • Add new mapping
  • Extension: .* 
  • Executable path: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll (or copy .aspx extension). Note, by default the file selector looks for .EXE files, so change to *.*. I looked at this blankly for a minute when I couldn't see the DLL I wanted! Doh...
  • Verbs: GET,HEAD,POST,DEBUG
  • Check file exists - No
  • Click Ok

Not for production, but good enough for your development machine! This post gave me the hint I needed: http://blogs.microsoft.co.il/blogs/dorony/archive/2007/12/15/using-asp-net-mvc-on-iis-5.aspx

N.B. If you find that the Ok button is greyed out (it was for me), then click back in the Exectuable field and see if the Ok button is now available. If not, try any other extension rather than ".*" until the Ok button is enabled and then switch back to ".*". Worked for me.