This project is read-only.

An unexpected error has occurred while submitting story.

Sep 21, 2009 at 11:32 PM

When I try to submit a new story, I am getting this error message. I don't know what is wrong. Could anyone help me with this. 

 

I am using version 2.1. I did and followed the steps for the configuration. I submit only one story and that is it. In fact, on the first story, the site crashed and than when I refreshed the page, it worked. I did see the story submit but after that, I could never submit any other story again.

 

This is driving me crazy because I re-installed many times and same problem happens over and over.

 

Thank you in advance.

Sep 22, 2009 at 1:47 AM

I guess you are running a old version 2.1! Why don't you upgrade to 2.2 or 2.5 then try again! Lots of bug fixes added!

I would suggest to do so! especially I have no idea what is going on or be able to reproduce the issue on my local working version.

Personally I am running v2.5

Sep 22, 2009 at 2:05 AM

I tried the other versions but this time I am getting other errors. I wish there was a screen cast shows me the process on the install of the newer versions. The instruction text file isn't helping at all. I am following everything but I am still getting errors on the install. I can't even see the home page with the v2.5. That is even worse.

I will try the v2.5 but that doesn't even have default.aspx on the code download. Does it go to another page on default?

 

Thanks in advance!

 

 

Sep 22, 2009 at 2:25 AM

I also just installed Kigg 2.5, I don't know how to install (Indeed, the installation is real difficult to me:), the web hosting support team help me install the Kigg, my website is "http://www.servefault.com" hosted by webhost4life

Regards,

Helen

Sep 22, 2009 at 7:03 AM

I really wonder if you read the deployment guide that was just recently posted!

It is not yet fully complete! but at least the part that will let you run the application and start posting!

Yes there is no default.aspx! but don't worry everything should move fine. Just try the documentation for deployment.

In the provided documentation (online) I applied it to my local version, step by step and successfully was able to initially run the application!

Please let me know if the documentation isn't helping or need modifications.

 

Sep 22, 2009 at 7:51 AM

I have read it and gone through it maybe three times.

Still it isn't working. This is ridiculous. This should not be this difficult to lunch. If two different databases want to be supported, than two different download there should be. One for MySQL and one for MS SQL and last one for both if anybody (must be stupid) to support MySQL and MS SQL at the same time.

Here is the final errors I am getting and can't get rid of it:

PS: I have done the commands manually as well.

 

 

Error 102 Metadata file 'C:\Projects\KiggTest\EntityFramework\bin\Debug\Kigg.Infrastructure.EF.dll' could not be found Kigg.Web
Error 103 Metadata file 'C:\Projects\KiggTest\Web\bin\Kigg.Web.dll' could not be found Kigg.Web.Test
Error 104 An error occurred creating the configuration section handler for system.data: Column 'InvariantName' is constrained to be unique.  Value 'MySql.Data.MySqlClient' is already present. (C:\Projects\KiggTest\References\MySqlClient\EdmGen.exe.Config line 6) C:\Projects\KiggTest\EntityFramework\EXEC Kigg.Infrastructure.EF
Error 105 The command ""%windir%\Microsoft.NET\Framework\v3.5\edmgen.exe" /mode:EntityClassGeneration /incsdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.csdl" /outobjectlayer:"C:\Projects\KiggTest\EntityFramework\DomainObjects\Generated\Models.cs" /language:CSharp
"%windir%\Microsoft.NET\Framework\v3.5\edmgen.exe" /mode:ViewGeneration /incsdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.csdl" /inssdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.SqlServer.ssdl" /inmsl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.msl" /outviews:"C:\Projects\KiggTest\EntityFramework\DomainObjects\Generated\SqlServerViews.cs" /language:CSharp
"C:\Projects\KiggTest\References\MySqlClient\edmgen.exe" /mode:ViewGeneration /incsdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.csdl" /inssdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.MySql.ssdl" /inmsl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.msl" /outviews:"C:\Projects\KiggTest\EntityFramework\DomainObjects\Generated\MySqlViews.cs" /language:CSharp" exited with code 1. Kigg.Infrastructure.EF

Error 102 Metadata file 'C:\Projects\KiggTest\EntityFramework\bin\Debug\Kigg.Infrastructure.EF.dll' could not be found Kigg.Web

Error 103 Metadata file 'C:\Projects\KiggTest\Web\bin\Kigg.Web.dll' could not be found Kigg.Web.Test

Error 104 An error occurred creating the configuration section handler for system.data: Column 'InvariantName' is constrained to be unique.  Value 'MySql.Data.MySqlClient' is already present. (C:\Projects\KiggTest\References\MySqlClient\EdmGen.exe.Config line 6) C:\Projects\KiggTest\EntityFramework\EXEC Kigg.Infrastructure.EF

Error 105 The command ""%windir%\Microsoft.NET\Framework\v3.5\edmgen.exe" /mode:EntityClassGeneration /incsdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.csdl" /outobjectlayer:"C:\Projects\KiggTest\EntityFramework\DomainObjects\Generated\Models.cs" /language:CSharp

 

"%windir%\Microsoft.NET\Framework\v3.5\edmgen.exe" /mode:ViewGeneration /incsdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.csdl" /inssdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.SqlServer.ssdl" /inmsl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.msl" /outviews:"C:\Projects\KiggTest\EntityFramework\DomainObjects\Generated\SqlServerViews.cs" /language:CSharp

 

"C:\Projects\KiggTest\References\MySqlClient\edmgen.exe" /mode:ViewGeneration /incsdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.csdl" /inssdl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.MySql.ssdl" /inmsl:"C:\Projects\KiggTest\SharedFiles\DomainObjects.msl" /outviews:"C:\Projects\KiggTest\EntityFramework\DomainObjects\Generated\MySqlViews.cs" /language:CSharp" exited with code 1. Kigg.Infrastructure.EF

This point I can't pass.
I tried everything. I don't know what to do. This should be simple. If I want to use Entitiy Framework (which I do), my configuration should be for that. Simple as that.

 

Sep 22, 2009 at 9:15 AM

First of all there shouldn't be 2 separate packages for different database support because it is all a matter of configuration that is already documented.

I just downloaded the code on separate machine. I recompiled the code, and none of the above issues appeared! Even the commands run successfully! Which made me doubt the version you have or your machine system requirements!

I did the following:

1) downloaded the source code of the latest changeset or the one provided on download section
2) Opened KiGGEF.sln
3) rebuild the solution with debug option, release option and publishingrelease option and all went fine.

And it was just as easy as the above, totally independent machine with no prior KiGG deployment or development.

Now to deployment. The above is not related to deployment, The above is about source code an rebuild the solution.

To deploy you need to follow the steps provided in the documentation which again I followed up step by step and successfully deployed KiGG on another 3rd machine with windows vista SP2 on IIS 7.0!

Now do your machine have .NET 3.5 SP1 & ASP.NET MVC 1.0 RTM installed!

What edition of Visual Studio you are Using?

 

Sep 22, 2009 at 3:51 PM

I have the Visual Studio 2008 Team System. I have installed all the updates and .Net 3.5 SP1 & Asp.Net MVC 1.0 RTM as well. I am having the same problem over and over. Also, I have the IIS 7.0 on Vista.

I don't know if I am missing anything else. I have just rebuild my machine an a new hard drive. I have followed the instructions on the documentation about the installation.

Look I have MS SharedView. If you don't mind, could you take a look at it?

Sep 23, 2009 at 6:23 AM

Yes, I would like to have a look! because this is all weird! I want to know what is going wrong.

How can I access it? and when you'll be available?!

Sep 23, 2009 at 6:45 AM

Thank you in advance. 

 

I am avaliable right now and will be till 12:30 am.

 

You can call me as well.

My Skype user name is : ZeroInfinity

I will give you my phone number if you want and if you are in the Bay Area.

 

Let me know

 

Sep 23, 2009 at 10:25 AM

Look, currently I am at work, won't be able to do it now.

However I'll be available at 7 PM my local time. my time zone is GMT +2. What is yours?

I'll add you to skype once I got access to my laptop when I get back to home. btw, I am in Cairo.

Sep 23, 2009 at 7:07 PM

Hi,

 

I am at GTM Pacific time. I live in San Francisco Bay Are.

Let me know.

Dec 15, 2009 at 5:37 AM

Hi mosessaur, I meet the same error with ZeroInfinity, could you tell me how to fix it please?

Feb 6, 2010 at 4:23 PM

And I have the same problem as ZeroInfinity. How can I fix it?

Feb 21, 2012 at 11:02 AM

I had the same error, to fix it, I opened the Kigg.Infrastructure.EF properties, then at the build events section, i have removed the last command for mysql as i don't have mysql and will use sql server

after that the project was building sucessfully