This project is read-only.

How can I configure KIGG for using google smtp server

Feb 10, 2010 at 3:25 PM

When I try to configure KIGG for using google smtp server, like this

<mailSettings>
  <smtp from="myemail@gmail.com" deliveryMethod="Network">
    <network host="smtp.gmail.com" port="465" userName="myemail@gmail.com" password="MyPassword" defaultCredentials="false"/>
  </smtp>
</mailSettings>

I have an error, while sending email. When I looked to the Send email method via debugger I saw that SmtpServer and Port properties in the base class of WeblogEmailTraceListenerData are empty. How can I fix this?

Mar 27, 2010 at 1:30 AM

Google requires SSL. To setup that, find your Unity configuration and look for the following

          <type type="IEmailSender" mapTo="EmailSender">
            <lifetime type="Singleton"/>
            <typeConfig extensionType="Microsoft.Practices.Unity.Configuration.TypeInjectionElement, Microsoft.Practices.Unity.Configuration">
              <constructor>
                <param name="templateDirectory" parameterType="System.String">
                  <value type="System.String" value="mailTemplates"/>
                </param>
                <param name="enableSsl" parameterType="System.Boolean"><value type="System.Boolean" value="false"/></param>
                <param name="settings" parameterType="IConfigurationSettings">
                  <dependency/>
                </param>
                <param name="file" parameterType="IFile">
                  <dependency/>
                </param>
              </constructor>
            </typeConfig>
          </type>

Note the bold parameter enableSsl, make sure to set the value to true